CIM via PowerShell

From vWiki
Jump to navigation Jump to search

Getting Started

The PowerShell components required (below), are only capable of being installed on Windows 6 and later (Vista, Win2k8, Windows 7). Windows XP and Windows 2003 are not capable of performing the remoting features required in order to be able to support WinRM (although this may change in future releases). See PowerShell Installed Version in order to determine what version of Powershell you have installed currently.

Useful Commands

New-WSManSessionOption

Get-WSManInstance

Get-View

  • Gets a vSphere .net object view

AcquireCimServicesTicket